$re = '/\bHYD(?:\.|\b)/';
$str = 'HYDRAULIC
HYD,CYLINDER
HYD,CYLINDER",
HYD. CYLINDER
HYD.,CYLINDER"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);