re = /\bHYD(?:\.|\b)/
str = 'HYDRAULIC
HYD,CYLINDER
HYD,CYLINDER",
HYD. CYLINDER
HYD.,CYLINDER"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end