$re = '/^(\d{2}\/\d{2})\s*(\d{1,2}:\d{2}\s*(PM|AM))\s*(\d+)\s*([^\d.]+)(\d+)\s*([^\d.]+)$/m';
$str = '12/16 7:00 PM 751 Appalachian State 752 Duke
12/16 7:00 PM 753 Chicago State 754 Indiana-Purdue
12/16 8:00 PM 755 Texas-Arlington 756 Oral Roberts
12/16 10:00 AM 757 Dartmouth 758 Stanford';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);