import re
regex = re.compile(r"^(\d{2}\/\d{2})\s*(\d{1,2}:\d{2}\s*(PM|AM))\s*(\d+)\s*([^\d.]+)(\d+)\s*([^\d.]+)$", flags=re.MULTILINE)
test_str = ("12/16 7:00 PM 751 Appalachian State 752 Duke\n"
"12/16 7:00 PM 753 Chicago State 754 Indiana-Purdue\n"
"12/16 8:00 PM 755 Texas-Arlington 756 Oral Roberts\n"
"12/16 10:00 AM 757 Dartmouth 758 Stanford")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")