using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[?&])id=[^&]*(?:&|$)";
string input = @"https://example.com/?id=iuyu1223-uhs12&event=update
https://example.com/?id=iuyu1223-uhs12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}