re = /(?<=[?&])id=[^&]*(?:&|$)/m
str = 'https://example.com/?id=iuyu1223-uhs12&event=update
https://example.com/?id=iuyu1223-uhs12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end