$re = '/(?<=[?&])id=[^&]*(?:&|$)/m';
$str = 'https://example.com/?id=iuyu1223-uhs12&event=update
https://example.com/?id=iuyu1223-uhs12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);