const regex = /^.*^((?:https?:)?\/\/)?(www\.)?(screencast\.com)(\/users)\/([a-z0-9_-]+)\/folders\/([a-z0-9%_-]+)\/media\/([a-z0-9_-]+)(?:\/)?$/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*^((?:https?:)?\\\/\\\/)?(www\\.)?(screencast\\.com)(\\\/users)\\\/([a-z0-9_-]+)\\\/folders\\\/([a-z0-9%_-]+)\\\/media\\\/([a-z0-9_-]+)(?:\\\/)?$', 'im')
const str = `https://www.screencast.com/users/arundquist/folders/General%20Physics%20II/media/e2ff7bd7-61ba-4325-b06b-8275e2b94f16
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}