re = /^.*^((?:https?:)?\/\/)?(www\.)?(screencast\.com)(\/users)\/([a-z0-9_-]+)\/folders\/([a-z0-9%_-]+)\/media\/([a-z0-9_-]+)(?:\/)?$/im
str = 'https://www.screencast.com/users/arundquist/folders/General%20Physics%20II/media/e2ff7bd7-61ba-4325-b06b-8275e2b94f16
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end