import re
regex = re.compile(r"^.*^((?:https?:)?\/\/)?(www\.)?(screencast\.com)(\/users)\/([a-z0-9_-]+)\/folders\/([a-z0-9%_-]+)\/media\/([a-z0-9_-]+)(?:\/)?$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://www.screencast.com/users/arundquist/folders/General%20Physics%20II/media/e2ff7bd7-61ba-4325-b06b-8275e2b94f16\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")