re = /(?s)\/export\/home(?:(?!\/export\/home).)*/
str = '/export/home/bla "123" "bla" test 1
/export/home/bla "123" "bla" test 2
/export/home/bla "123" "bla" test 3
test4
test5
/export/home/bla "123" "bla" test 6
/export/home/bla "123" "bla" test 7
/export/home/bla "123" "bla" test 8
test9
/export/home/bla "123" "bla" test 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end