package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\|)([a-z0-9-]+)(?:\|)`)
var str = `40|41be6f15-2e19-4e1d-aaff-d4b92ae47e48|0||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}