// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\|)([a-z0-9-]+)(?:\|)").unwrap();
let string = "40|41be6f15-2e19-4e1d-aaff-d4b92ae47e48|0||";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}