$re = '/(?:\|)([a-z0-9-]+)(?:\|)/m';
$str = '40|41be6f15-2e19-4e1d-aaff-d4b92ae47e48|0||';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);