import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)\\w{2}(-\\w{2})?(?=\\/)";
final String string = "/en/home.aspx\n"
+ "/en-gb/ts/tc/home.aspx\n"
+ "/en-gb/home.aspx\n"
+ "/en-de/home.aspx\n"
+ "/de-de/home.aspx\n"
+ "/en/home.aspx\n"
+ "en-fb/afspfas.aspx\n"
+ "/en-gb/ts/ca/anotherPage.aspx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}