import re
regex = re.compile(r"(?<=\/)\w{2}(-\w{2})?(?=\/)", flags=re.MULTILINE)
test_str = ("/en/home.aspx\n"
"/en-gb/ts/tc/home.aspx\n"
"/en-gb/home.aspx\n"
"/en-de/home.aspx\n"
"/de-de/home.aspx\n"
"/en/home.aspx\n"
"en-fb/afspfas.aspx\n"
"/en-gb/ts/ca/anotherPage.aspx")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")