re = /(?<=\/)\w{2}(-\w{2})?(?=\/)/m
str = '/en/home.aspx
/en-gb/ts/tc/home.aspx
/en-gb/home.aspx
/en-de/home.aspx
/de-de/home.aspx
/en/home.aspx
en-fb/afspfas.aspx
/en-gb/ts/ca/anotherPage.aspx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end