using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z]1.*?[A-Za-z]1";
string input = @"a1bcd2345ea1ABCa1DEFa1
C1abdrFECsarR1C1abdrFECsarR1
r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}