const regex = /^[A-Za-z]1.*?[A-Za-z]1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z]1.*?[A-Za-z]1', 'gm')
const str = `a1bcd2345ea1ABCa1DEFa1
C1abdrFECsarR1C1abdrFECsarR1
r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}