$re = '/^[A-Za-z]1.*?[A-Za-z]1/m';
$str = 'a1bcd2345ea1ABCa1DEFa1
C1abdrFECsarR1C1abdrFECsarR1
r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);