package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s@]@[^\s@]+`)
var str = `From stephen.marquard@uct.ac.za Sat Jan 5 09:14:16 2008`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}