$re = '/[^\s@]@[^\s@]+/m';
$str = 'From stephen.marquard@uct.ac.za Sat Jan 5 09:14:16 2008';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);