re = /[^\s@]@[^\s@]+/m
str = 'From stephen.marquard@uct.ac.za Sat Jan 5 09:14:16 2008'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end