# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\/(M\w+)-(\d+).*/\1\2/gm;t' <<< "https://auto.mercadolibre.com.ar/MLA-723950998-peugeot-208-0km-16-active-plan-100-financiado-darc-_JM"