use strict;
my $str = 'https://auto.mercadolibre.com.ar/MLA-723950998-peugeot-208-0km-16-active-plan-100-financiado-darc-_JM';
my $regex = qr@.*/(M\w+)-(\d+).*@mp;
my $subst = '\\1\\2';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";