re = /.*\/(M\w+)-(\d+).*/m
str = 'https://auto.mercadolibre.com.ar/MLA-723950998-peugeot-208-0km-16-active-plan-100-financiado-darc-_JM'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result