# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(n)ounC2|(v)erbC1|(adj)ectiveB1/ ($1$2$3)/gm;t' <<< "dangernounC2
cautionnounC2
alertverbC1
dangerousadjectiveB1
eatverbC1
prettyadjectiveB1"