# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(n)ounC2|(v)erbC1|(adj)ectiveB1"
test_str = ("dangernounC2\n"
"cautionnounC2\n"
"alertverbC1\n"
"dangerousadjectiveB1\n"
"eatverbC1\n"
"prettyadjectiveB1")
subst = " ($1$2$3)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.