import Foundation
let pattern = #"(n)ounC2|(v)erbC1|(adj)ectiveB1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dangernounC2
cautionnounC2
alertverbC1
dangerousadjectiveB1
eatverbC1
prettyadjectiveB1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" ($1$2$3)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)