using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?31(.{0,34})?(?=\?[0-9]{2}|$)";
string input = @"?31DE16170619340006562160?32Jan Doufe
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}