$re = '/\?31(.{0,34})?(?=\?[0-9]{2}|$)/';
$str = '?31DE16170619340006562160?32Jan Doufe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);