re = /\?31(.{0,34})?(?=\?[0-9]{2}|$)/
str = '?31DE16170619340006562160?32Jan Doufe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end