#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^a-zA-Z]|^)([a-zA-Z]{1,2})$"
Local $sString = "Example:" & @CRLF & _
" -- to be matched$" & @CRLF & _
"ny12345d" & @CRLF & _
"ny12345dc" & @CRLF & _
"" & @CRLF & _
" --not to be matched$" & @CRLF & _
"ny12346T01" & @CRLF & _
"ny12346dfA" & @CRLF & _
"ny12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")