use strict;
my $str = 'Example:
-- to be matched$
ny12345d
ny12345dc
--not to be matched$
ny12346T01
ny12346dfA
ny12345';
my $regex = qr/(?:[^a-zA-Z]|^)([a-zA-Z]{1,2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}