using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^a-zA-Z]|^)([a-zA-Z]{1,2})$";
string input = @"Example:
-- to be matched$
ny12345d
ny12345dc
--not to be matched$
ny12346T01
ny12346dfA
ny12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}