using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<requestedURI>\/api[^\d\s?]*[^\d\s?\/])(?:[^\s]+)? \S+\s+\d+\s+\d+\s+(?<requestProcessedTime>\d+)$";
string input = @"12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/session?timestamp=1706101022929 HTTP/1.1 200 40 25
12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/8547 HTTP/1.1 200 40 25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}