import Foundation
let pattern = #"(?<requestedURI>\/api[^\d\s?]*[^\d\s?\/])(?:[^\s]+)? \S+\s+\d+\s+\d+\s+(?<requestProcessedTime>\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/session?timestamp=1706101022929 HTTP/1.1 200 40 25
12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/8547 HTTP/1.1 200 40 25
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)