$re = '/(?<requestedURI>\/api[^\d\s?]*[^\d\s?\/])(?:[^\s]+)? \S+\s+\d+\s+\d+\s+(?<requestProcessedTime>\d+)$/m';
$str = '12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/session?timestamp=1706101022929 HTTP/1.1 200 40 25
12:57:03.106 [default-nioEventLoopGroup-1-9] INFO test-access-logger localhost.internal [24/Jan/2024:12:57:03 +0000] GET /api/test/user/8547 HTTP/1.1 200 40 25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);