using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([ftY])(?:AW|MS|\d+)";
string input = @"15 YstfAWIN25
15 YstfMSIN25
15 Ystf20IN25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}