$re = '/([ftY])(?:AW|MS|\d+)/m';
$str = '15 YstfAWIN25
15 YstfMSIN25
15 Ystf20IN25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);