package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([ftY])(?:AW|MS|\d+)`)
var str = `15 YstfAWIN25
15 YstfMSIN25
15 Ystf20IN25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}