$re = '/\b(?:apples?|pears?|strawberry|strawberries|grapes?)\b/i';
$str = 'Today I ate an apple, then a pear, then a strawberry. This is my article and it\'s about apples and pears. I like strawberries as well though.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);