import re
regex = re.compile(r"\b(?:apples?|pears?|strawberry|strawberries|grapes?)\b", flags=re.IGNORECASE)
test_str = "Today I ate an apple, then a pear, then a strawberry. This is my article and it's about apples and pears. I like strawberries as well though."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")