re = /\b(?:apples?|pears?|strawberry|strawberries|grapes?)\b/i
str = 'Today I ate an apple, then a pear, then a strawberry. This is my article and it\'s about apples and pears. I like strawberries as well though.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end