#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<variable\s[^>]*?name=['"]test['"][^>]*>(.*?)<\/variable>"
Local $sString = "<variable data-id="1" name="test2" style="background-color:red;">Variable test</variable> isto é texto <variable style="background-color:red;" name="test" data-id="2">Variable Test2</variable> outro texto"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")