re = /<variable\s[^>]*?name=['"]test['"][^>]*>(.*?)<\/variable>/m
str = '<variable data-id="1" name="test2" style="background-color:red;">Variable test</variable> isto é texto <variable style="background-color:red;" name="test" data-id="2">Variable Test2</variable> outro texto'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end