using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<variable\s[^>]*?name=['""]test['""][^>]*>(.*?)<\/variable>";
string input = @"<variable data-id=""1"" name=""test2"" style=""background-color:red;"">Variable test</variable> isto é texto <variable style=""background-color:red;"" name=""test"" data-id=""2"">Variable Test2</variable> outro texto";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}