import re
regex = re.compile(r"({.+})")
test_str = ("Erreur PHP\n\n"
"{\"okko\":\"OK\",\"valeur\":\"706,999\",\"listeIdentLib\":{\"706\":\"Picard\",\"999\":\"BASE QUALIF\"},\"valOpeR\":\"\",\"statut\":\"ADM\"}\n\n"
"TOTO")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")