re = /({.+})/
str = 'Erreur PHP
{"okko":"OK","valeur":"706,999","listeIdentLib":{"706":"Picard","999":"BASE QUALIF"},"valOpeR":"","statut":"ADM"}
TOTO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end