use strict;
my $str = ' 0
down vote
favorite
I have a thousand html pages (without admin panel) with codes of adsense. And I want to remove all of them from html. One code looks like:
<ins class="adsbygoogle"
style="display:inline-block;width:160px;height:600px"
data-ad-client="ca-pub-7165746718333100"
data-ad-slot="9087512399"></ins>
Another:
<ins class="adsbygoogle"
style="display:inline-block;width:160px;height:600px"
data-ad-client="ca-pub-7163746711373100"
data-ad-slot="7467236139"></ins>
All of them are similar but not equal. A tried to write regex to find and replace it with empty string, but unsuccessfully.
Any suggetion how to do it automatically?
';
my $regex = qr~(?s:
<ins
(?:(?!</ins>).)*?
"adsbygoogle"
.*?
</ins>)~xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}